PDA

View Full Version : install cURL?


doma79
07-21-2009, 11:07 AM
I've just had a problem brought to my attention (who knows how long it's been there)

Our online payment system is broken right at the point where transaction details are sent to the 3rd party company for processing. We get the following error.

"Fatal error: Call to undefined function curl_init() in /home/......."

From some quick googling I think cURL has been uninstalled (or not properly re-installed). I know for certain it was working about a month ago and nothing has changed since.

I've submitted a support ticket but would appreciate any hints other people might have to help me get this working ASAP.

cheers
damo

doma79
07-21-2009, 06:06 PM
Any chance some one could look at this support ticket?

QAJ-310451

Would be great to know when it will be looked at.

cheers
damo

doma79
07-22-2009, 10:58 AM
Any chance of any sort of response?

admin
07-22-2009, 01:37 PM
Sorry for this issue taking a long time. It requires a lot of changes to be made, we have to rebuild Apache and PHP and in order to do that we have to update cpanel also, so the rebuild software is all updated. Shouldn't be too much longer.

Russell
07-24-2009, 08:26 AM
Sorry for this issue taking a long time. It requires a lot of changes to be made, we have to rebuild Apache and PHP and in order to do that we have to update cpanel also, so the rebuild software is all updated. Shouldn't be too much longer.
I'm looking forward for it too, hope it'll be compiled on US NS1 as well.

Thanks doma79 for bringing up the topic.

admin
07-24-2009, 08:46 AM
Unfortunately there is an issue with easyapache on the NS1 server. If u need curl then please submit a support ticket & we can migrate your account/s to the NS2 server, which has curl builtin to PHP already. Easyapache is the cpanel Apache/PHP builder, current rebuilding on NS1 fails.

doma79
07-24-2009, 09:19 AM
Any idea why it suddenly stopped working on NS1?

admin
07-24-2009, 10:58 AM
Yes it would have been about 1 month ago when we installed eaccelerator. I remember that at that time I had to disable curl in PHP in order to build Apache with eaccelrator, for some reason I remember each time I tried to build curl in PHP it also failed then too. But for some unknown reason it worked on NS2 and I was able to build eaccelerator and curl with no problems. I don't know why.

Its not eaccelerator because I can't build Apache / PHP with or without eaccelerator. It just seems to be something with curl, can't build it on th eNS1 server, generates errors during the build process. I will get cpanel to look into it.

admin
07-24-2009, 08:35 PM
Ok this has been solved now, clients account moved to NS2 server.